Routing, Switching, and Trunking Lab

 


This lab explores basic configurations to practice routing, switching, and trunking, we practice in this some known networking concepts like DHCP agent relay, VTP domains, 802.1Q encapsulation

you can download the lab at thekeithbarker.com under the name "Cisco PT DHCP, Routing, Switching 2020-04-07" 

extract the files, open the ".pkt" file and follow along with me 

Lab Objective: 

  • PCs 1,3 in VLAN 10, Subnet 10.16.0.0 /24
  • PCs 2,4 in VLAN 20, Subnet 172.16.0.0/24
  • DHCP assigned addresses for PCs
  • DHCP/Web server in VLAN 777, Subnet 192.168.1.0/24, using .100
  • Default G/W is .1 in each subnet
  • Verify if clients can ping each other
  • Verify if clients can open the web page of the server at TheKeithBarker.com


First configuration on our switches

configuration terminal
no ip domain-lookup
line console 0 
logging synchronous
no exec-timeout
privilege level 15
spanning-tree mode rapid-pvst
spann portfast default
end 
write


Create trunks & VTP domain 

  • Sw1
conf t
vtp domain axa
int range fa 0/11, fa 0/22, g0/1
switch mode trunk
end

  • Sw2
conf t
vtp domain axa
int range fa 0/11, fa 0/22, g0/2
switch mode trunk
end

  • Sw3
conf t
vtp domain axa
int range g0/1-2
sw trunk encapsulation dot1q 



Create the VLANs on one switch (VTP will copy them to the other switches)

conf t
vlan 10
vlan 20
vlan 777


Configure access ports 

  • Sw1
configure terminal 
int fa0/1 
switchport mode access
switchport access vlan 10
int fa0/2
switchport mode access
switchport access vlan 20

  • Sw2
conf t 
int fa0/3 
switchport mode access
switchport access vlan 10
int fa0/4 
switchport mode access
switchport access vlan 20
int fa0/5
switchport mode access
switchport access vlan 777


Configure DHCP Server

verify the Server's IP address
Desktop > IP Configuration > 192.168.1.100/24 


Create the DHCP pools

Services > DHCP > turn the service ON > VLAN10 pool > fill all information > Add


same for the VLAN20 pool


Configure routing with SVI (Switch virtual interface) on Sw3 (L3 Switch)

conf t
interface vlan 10 
ip add 10.16.0.1 255.255.255.0
interface vlan 20
ip add 172.16.0.1 255.255.255.0
interface vlan 777
ip add 192.168.1.1 255.255.255.0
end 
sh ip int br




try to ping those Gateway addresses


if you try to make the PCs request DHCP it won't work now, we need another configuration

Configure Sw3 to act like a DHCP relay agent 

int vlan 10 
ip helper-address 192.168.1.100
int vlan 20
ip helper-address 192.168.1.100
end

Ask for DHCP addresses and open the web page at TheKeithBarker.com

go to any PC > Config > check DHCP box


go to any PC > Desktop > Web Browser > type TheKeithBarker.com



Congratulations, you completed the Lab






Comments

Popular posts from this blog

OpenVas: Vulnerability Scanning | Installation Guide

Nmap | TryHackMe Walkthrough

Azure Sentinel: Use Microsoft's SIEM to map global attacks